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Overview 
This guide provides an overview of the procedures available to users with Admin Manager 
privileges. Images in this guide are from Windows 10 with Internet Explorer 11. Your screens 
may differ with a different OS or browser.  
TotaleAtlas, TotaleAtlas RTS, TeA and TeARTS are generic terms for IMM eSign. In this guide 
text and screen shots may use any of these terms. 
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Getting Started 
The eSign Admin Manager Administrator will define document templates for use in the IMM 
eSign system. As part of that process, field and party information regions will be defined. 
 

 
PDF documents used for AIM definitions cannot be password protected and cannot 
have any security that prevents data extraction. 

 
Before being able to use a document in IMM eSign, the administrator first needs to define a 
document using a document template. This involves loading your PDF document into the 
eSign Admin Manager, and then giving the document a unique name, defining index fields 
and designing additional information fields. When defining a document and document regions, 
you will first select an item (Document Type, Party Information, Text Field, etc.) and then use 
the mouse to highlight the region on the document, as indicated in the following procedures. 

1. Planning and Indexing  
2. Starting Admin Index Manager 
3. Creating a Document Template 
4. Defining FI Level Index Information 

a. Add/Edit/Define index field, including custom index fields 
i. Set FI-wide default values 
ii. Set custom functions 

5. Loading a Document 
6. Defining a Document Type 
7. Defining FI Level Index Field Regions 
8. Modifying Document Level Indexing 

a. Set document level custom functions 
b. Set document level index field default values 

9. Defining Text Fields 
10. Defining Checkbox Fields 
11. Defining Signature Fields 
12. Defining Initial Fields 
13. Defining Party Information 
14. Closing a Document 
15. Managing Attached Documents 
16. Exporting and Importing Defined Documents 
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Planning and Indexing 
Before defining documents, you should be familiar with indexing and archiving. You should 
know which fields will be required for indexing, which text, checkbox and signature fields will 
need to be added to the documents, and you should know what party information will need to 
be added for Remote Signatures (Optional). 
Index Fields 
Index fields are used for your document indexing and archiving systems. Indexes are 
necessary for your imaging system to successfully archive your document.  
In IMM eSign RTS, there are 2 levels of indexing. 
FI Level Indexing 

Indexing information defined and applied at the FI (Financial Institution) level applies to all 
documents processed through IMM eSign RTS. FI Level index fields can be edited or 
modified before defining a document or while a document is being defined. Custom Index 
Fields are created and modified at the FI Level. 
Document Level Indexing 

Some index field information for individual documents can selectively be modified separately. 
Document Level Indexing changes takes precedence over FI Level Indexing. Document Level 
index fields can only be modified during the document definition process. Custom Index 
Fields may be also modified at the Document Level. 
Information Fields 
Text, checkbox and signature fields are used to add additional information to completed 
documents. Procedures for adding these fields are included later in this guide. 
Party Information Fields 
Party information fields are used to transfer information from documents to eSignature, 
allowing documents to be viewed and signed via the web.  Refer to Defining Party 
Information on page 58 for more information. 



  IMM eSign 2019.2 SP1 
  Admin Manager Administrator Guide 

2/5/20  7 

Starting Admin Index Manager 
First Time Logon 

1 Click Start > All Apps > IMM > Index Manager. 
The first time eSign Admin Manager is started, the Preferences window appears and 
the Host System FIID will be blank. 
This window also appears from within eSign Admin Manager by clicking Edit > 
Preferences. Refer to Edit Preferences on page 10. 
Click Edit to unlock. 
 1 Verify the Web Service URL. 

 
This is TeSign.asmx, not Login.asmx. 
Web Service URL addresses use the .asmx extension. 
The URL prefix (HTTP/HTTPS) must match the prefix selected during 
the server components installation.  
eSign Admin Manager must be restarted if the Web Service URL is 
changed. 

 2 Enter the Host System FI ID. This is the FI ID established when the FI was 
created.  

 3 Enter the Host FIID Password. This is the FI Access Password as set by the 
Host Administrator during FI creation or modified under Change FI Access 
Password. 

 4 Click Save. 

 

 
 Indicates the FI ID has not been verified. 

The Preferences window can be opened again as necessary. 

1
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

 

2 

 
3 

 

4 
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2 The Enter eSign Credentials window appears with the Host System FI ID populated 
from the previous step. 

• Host System FIID: Preset during installation. 
• Domain: Preset during installation. 
• User ID: ID of user logging into eSign Admin Manager based on the Windows 

login.  

 
This user ID must be created by the FI Admin prior to this step. 

 1 RTS Password: This is the RTS Password which is assigned to the User ID in 
eSign RTS User Maintenance.  

 2 Click OK to continue. 

 
If any information on this screen is incorrect, you will be returned to the previous 
screen. 

1 

 

2 
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3 
 

This warning will appear if you are not authorized to define documents 
through the eSign Admin Manager. 

 
The user running eSign Admin Manager must be a member of the 
DocumentAdmins or Administrators group. Refer to the FI Administrator 
Guide for more information. 

 

4 The eSign Admin Manager screen appears. 

 
The current FI ID appears in the lower right corner of the window.  
Hover the mouse pointer over the FI ID to display more information. 

 

Current FIID 
Hover the mouse to display 

more information 
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Edit Preferences 
When you are defining documents for multiple Financial Institutions, use Edit Preferences to 
point AIM to a different FI or server. 

1 From the eSign Admin Manager screen, 
Click Edit > Preferences. 
In the Preferences window, 
Click Edit. 

2 Change the following options as necessary: 
 1 Web Service URL 

 
Web Service URL addresses use the .asmx extension. 
The URL prefix (HTTP/HTTPS) must be the prefix selected during the 
server components installation. 

 2 Host System FIID 
 3 Host FIID Password 
 4 Zip Files Folder (Only appears if the TeSign Zip Add-On is enabled.) 
 5 Restart AIM. 

 

 
eSign Admin Manager must be restarted if the Web Service URL is 
changed. 

 

 

1 

 
2 

 
3 

 
4 

 

5 
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Creating a Document Template 

In order to process or define a document, the document template first needs to be converted 
to PDF format. 
A document template is a PDF document used to define Field and Party Information regions 
and locations within the document. If the documents that you would like to use in eSign are in 
any format other than PDF, you can convert your non-PDF document into a PDF document 
by printing it using the eSign Admin Printer, which will convert the document to PDF format.  

 
Before creating your PDF document template, you may find it helpful to populate the 
field regions in the template with sample information. This will allow you to more 
easily select and define the regions later. 

 

 
This function is not supported in Thin-Client installations. 

Open the document.  

 
 1 Click File > Print. 
 2 Select the eSign Admin Printer. 
 3 Click Print. 
The document will be converted to PDF format and placed in the 
IMM\TotaleSign\Admin\IndexFiles folder. 
Repeat as necessary to create additional PDF files. 

2 

3 

 

1 
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After the PDF document has been created proceed to Defining FI Level Index Information 
on page 13 or Loading a Document on page 17. 
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Defining FI Level Index Information 
Add/Edit/Define Index Fields 

 
A total of 20 index fields (including any predefined index fields) may be defined for 
each FI.  

From the TotaleSign Admin Index Manager screen,  
Click Fields > View/Change Index Types. 
The View/Change Index Field Types screen appears. 

 
The fields and values on this screen are applied to all documents indexed for a Financial 
Institution. This can be thought of as FI-Level Indexing. Document Level Indexing is 
performed in Modifying Document Level Indexing. 
The section highlighted in red lists both Default (Predefined) and Custom Index Fields that 
have been defined for your Financial Institution (FI). 
The action button area (highlighted in green) contains: 

• Delete Selected: Used to delete custom index fields only. Predefined Index Field Types 
cannot be deleted.  

• Close: Closes this screen. If custom index information has been completed, or if changes 
are made to the field information in the upper part of the screen, the changes are saved.  

The Add New Index Type part of this screen (highlighted in blue) allows defining Custom 
Index Fields. 
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The upper part of this screen lists Default (Predefined) and Custom Index Fields that have 
been defined for your Financial Institution (FI). 

 
The information from the Add New Index Type pane appears along with additional settings for 
the index type. 

 
1. Index Field Type, Title and Max Length for default fields cannot be changed. 
2. Index Field Type for custom fields cannot be changed. 
3. All other field information can be modified on this screen. Click in the text 

box as necessary to change.  
4. When editing field information in the upper part of the screen, you must click 

out or tab out of the field before clicking Close. 
• Index Field Type: Enter the Index Field Name. All custom Index Field Types must start 

with the prefix “CSTM_” (including the underscore). [Required] Cannot be changed on this 
screen. 

• Title: Enter the Title of the Index Name. (This title is also used as the Index column title or 
Index Search Field title in IMM eSign.) [Required] 

• Max Length: A numeric length of the field. [Required] 
• Default for Search Active: When this checkbox is checked, the index field is used, by 

default, as a search parameter on the Search Active Sessions screen in the IMM eSign 
interface. [Optional] 

• Default for Search Completed: When this checkbox is checked, the index field is used, by 
default, as a search parameter on the Search Completed screen in the IMM eSign 
interface. [Optional] 

• Use For Imaging: When this checkbox is checked, imaging will use the field in indexing. 
Only fields checked for imaging will be available for Document Level Indexing. [Optional] 

• External Index: This is an FI Level only setting and is used to allow matching of the Index 
Field Type with an Index Field Name supplied in an XML file used with specific 
Host/Imaging system combinations. If blank, the Index Field Type name is used. [Optional] 

• Imaging Index Name: Changes the Field Name in the generated XML, which is used by 
the imaging system. (Only displays for select imaging systems.) 

• Smart Index Lookup: The Smart Index Lookup column determines if that index field will be 
used to populate other index information from the SmartIndex database. The only valid 
values for this are true or blank – false is not used. (Only displays for select imaging 
systems.) 

• Formatted: The Formatted column informs an external index database that TotaleAtlas 
data for that index field is formatted. (Checked – eSign RTS data is formatted. Not checked 
– eSign RTS data is not formatted.) 

• Custom Function (1-5): Custom functions may be used to modify the actual data stored in 
associated .XML files. You can replace characters, delete characters, change date formats, 
etc. Refer to the Custom Function Guide for detailed information and examples. 



  IMM eSign 2019.2 SP1 
  Admin Manager Administrator Guide 

2/5/20  15 

Add New Custom Index Field 
The Add New Index Type part of this screen is used to define Custom Index Fields. 
 1 Index Field Type: Enter the Index Field Name. All custom Index Field Types must start 

with the prefix “CSTM_” (including the underscore). [Required]  
 2 Title: Enter the Title of the Index Name. (This title is also used as the Index column title 

or Index Search Field title in IMM eSign.) [Required] 
 3 Max Length: A numeric length of the field. [Required] 
 4 Default for Search Active: When this checkbox is checked, the index field is used, by 

default, as a search parameter on the Search Active Sessions screen in the IMM eSign 
interface. [Optional] 

 5 Default for Search Completed: When this checkbox is checked, the index field is used, 
by default, as a search parameter on the Search Completed screen in the IMM eSign 
interface. [Optional] 

 6 Use for Imaging: When this checkbox is checked, imaging will use the field in indexing. 
Only fields checked for imaging will be available for Document Level Indexing. [Optional] 

 7 External Index Name: This is an FI Level only setting and is used to allow matching of 
the Index Field Type with an Index Field Name supplied in an XML file used with specific 
Host/Imaging system combinations. If blank, the Index Field Type name is used. 
[Optional] 

After entering the required field information, 
 8 Click Add Index Type to add the Custom Index Field to the document definition 

database, which will then appear in the upper part of the screen. 

 

 

2 

 

1 

 

3 

 
4 

 

5 

 

6 

 7 

 
8 
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Delete Custom Index Field 

 
A custom field can only be deleted if it is not associated with any document. 

 1 Select a custom field.  
 2 Click Delete Selected. 

 
A confirmation window appears. 
Click Yes to delete the field. 
The screen updates showing the field has been deleted. 
 

1 

 

2 
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Loading a Document 
There are 2 methods of loading documents: Load Local Document and Load Document 
from Defined Document List. Both methods are discussed in the following procedures. 

 
PDF documents used for AIM definitions cannot be password protected and cannot 
have any security that prevents data extraction. 

Load Local Document 
Documents can be loaded from any location. The default location is  
C:\Program Files (x86)\IMM\TotaleSign\Admin\IndexFiles. 
Click Start > Programs > IMM > TotaleSign > Admin > Index Manager. 

 
The first time eSign Admin Manager is started, the Preferences window appears. 
Refer to Starting Admin Index Manager on page 7. 
The FI ID appears in the lower right corner of the window. Refer to IMM eSign 
Admin Index Manager Screen Layout on page 20 for more information. As 
documents are defined, document copies are placed on the server in the 
SourcePDFs folder for the FI selected when defining the document. 

 

1 From the eSign Admin Manager window, 
Click File > Load Local Document. 
Or 

Click the Load Local Document icon . 
The Select a PDF Document to Load window appears. 

 
If you are defining several documents, copy them to the default location of 
C:\Program Files (x86)\IMM\TotaleSign\Admin\IndexFiles. 
This will prevent having to navigate to a new location to open each 
document. 

Navigate to the PDF location. 
Select a PDF.  
Click Open. 
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2 The document loads into eSign Admin Manager. 

 
The currently opened document can be closed by clicking File > Close 
File. 

 
Proceed to IMM eSign Admin Index Manager Screen Layout on page 20. 

 

Load Document from Defined Document List 
1 From the eSign Admin Manager window, 

Click File > List Defined Documents. 
Or 

Click the List Defined Documents icon . 
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2 The Defined Documents List window appears. 

 
• Column definitions are listed under the Extraction Details window on page 24.  
• The top row in each column allows filtering the selection.  

o Filters are data-specific (text or Boolean). 
o The default text filter selection, or constraint, is “Contains” and the default value 

is empty, which causes all rows to appear. The default data filter selection is 
“Equals”, which filters based on the icon in the filter row. 

o Click the filter icon to choose a type of constraint. Click the constraint (Contains, 
Starts with, etc.) to enter text. 

Select the document. 
Click Open Selected. 
The document loads into eSign Admin Manager. 
All defined elements will appear in the left panel. 

3 If this message appears, 
Click OK. 

 
Have the IMM eSign Server Administrator perform Imported Documents 
Permissions on page 85. 

 

Filter Row 

Non-AIM 
Document 
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IMM eSign Admin Index Manager Screen Layout 

 

 Load a local document. (File > Load Local Document) 

 List defined documents. (File > List Defined Documents) 

 Define a new document type. (File > New > New Document Type)  

 Define new indexes for the document. (File > New > Define New Index)  

 Add or edit text fields for the document. (Fields > Design Text Fields) 

 
Define new Check Box fields in the document. (Fields > Design Checkbox 
Fields) 

 
Define new signature fields in the document. (Fields > Design Signature Fields) 
[Disabled in Dynamic Documents] 

 
Define initial fields in the document. (Fields > Design Initial Fields)  
[Disabled in Dynamic Documents] 

 
Define party fields in the document. (Party > Add Party Information) (Shift-F5) 
[Disabled in Dynamic Documents] 

/  Go to Beginning/ Go to End of the document. (View > Go to > First/Last) 

/  Go to Previous/Next page of the document. (View > Go to > Previous/Next) 

/  Zoom Out/ Zoom In. (View > Zoom > Zoom In/Out) 

 Zoom to Actual Size. (View > Zoom > Actual Size) 

 Zoom to Full Height. (View > Zoom > Fit Height) 

 Zoom to Full Width. (View > Zoom > Fit Width) 

 View Indexes. (View > Indexes) [Document Level Indexing] 
 

 

 

Selecting the Document Type highlights all defined indexes and 
fields across pages. 
Selecting Document Indexes highlights all defined indexes in 
orange across pages. 
Selecting a specific field highlights the index in green and displays 
the page in which it is defined for a multi-page document. 

 

Menu Bar Icons 

Defined Field List 

Information Area 

Page Numbers  

Current FIID 
Hover the mouse to display 

more information 

Host ID: IMM 
Host FIID: eSign 
FIID: 2 
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Defining a Document Type 
The document’s unique name is used to locate and file the document.  
Index fields are used in creating filenames for processed documents and document sets.  
Additional fields are used to extract additional information from the document. 
These procedures will discuss defining document information for new documents. Refer to 
Exporting and Importing Defined Documents on page 79 for information on modifying 
previously defined documents. 

Static Documents, Dynamic Documents and Image-Based Documents 
What’s the difference? 

Static Documents 
Static documents will always be the same length or number of pages and the layout is fixed 
and non-variable. All information in static documents will always be located in the same 
regions. The Signature Field and Signature Date Field will always be in the same locations on 
the same page.  

Dynamic Documents 
Dynamic documents can vary in the number of pages included. Mortgage documents can be 
one page in some cases and nine or more in other cases. may sometimes be 1 page long or 
9 pages or more in other cases. Typically, these documents require that an applicant read the 
information and then sign the documents at the end, attesting that the applicant has read the 
required information. In dynamic documents the Signature Field and Signature Date field can 
always be anywhere in the document regardless of the number of pages included. Document 
or template information should still be in a fixed location for eSign to extract the data. 
Dynamic documents do not allow adding party information, initials fields or signature fields 
when a document is defined. 

Image-Based Documents 
Image-based documents are a special type of PDF document that consists entirely of an 
image. There is no text and there are no characters—no character data for extraction with 
eSign. The areas to be defined (index and party information) must contain graphic 
information, such as graphical representations of characters, and the OCR (Optical Character 
Reader) capability of eSign will extract information from defined graphic areas. 

 
Changing document type (static, dynamic or image-based) after the document has 
been defined is not supported. If you need to change the document type, refer to 
Deleting a Document Definition on page 68. 
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Defining the Document Type 
1 Click the New Document Type icon (File > New > New Document Type) (Shift-F3). 
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2 The mouse cursor changes. 
Click and drag the mouse over the region of the document that contains text 
information unique to that document. In this case the title is Application Summary, but 
we have used a unique form number for the document.  

 
Note: If the text you are highlighting is very close to other text on the page, use the 

Zoom In function so you can more accurately highlight only the text you need. 

 
Right-click the mouse button or press the Escape key to reset the selected 
region. 

Click the mouse again when you complete highlighting the region on the document. 
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3 The Extraction Details window appears. 

 
Any and all highlighted text will appear in the Selection Text field on the Extraction Details 
window. Complete the form as necessary. 

• Short Name: Used in creating the filename for saved sessions. The Short Name is 
used for the Document Set Name on the Saved Session Details screen. (20 
characters maximum) 

 
Short Name and Full Name can only have A-Z, 1-9 and Underscore (_). 
Spaces are not allowed. 

• Full Name: Used in creating the filename for archived documents. The Full Name 
is used in indexing and defaults to the current filename, but can be modified at this 
point. (100 characters maximum) 

• Description: Used on the Saved Session Details screen for the Document 
Description column. An easy to recognize description of the document. (150 
characters maximum) 

• Display Document While Processing: When checked and documents are 
processed, the documents will appear during processing by default. When not 
checked the document may still be optionally used while processing. 

• Dynamic Document: When checked, the document will contain dynamic fields - 
fields that may appear in different locations in a document. 

 
1. Changing document type (dynamic vs. static) after the document 

has been defined is not supported.  
2. Party information, signature fields, signature date fields and initial 

fields cannot be used in Dynamic Documents. 

• Archive Document: When checked, the document will always be archived when a 
session is complete. When not checked, the document may still be optionally archived. 
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• Electronic Vault Document: Checked documents are sent to an Electronic Vault 
for auditing and tracking of the original document. When Electronic Vault 
documents are included in a session, all documents in the session will be sent to 
Electronic Vault for auditing and tracking.  
o The Electronic Vault helps ensure electronic documents remain legally 

admissible and enforceable. The Electronic Vault permanently binds electronic 
signatures to a document, creating a tamper-proof audit trail.  

• Perform OCR (Only for Image-Based Documents): When checked, the 
document is processed as an image-based document. To function correctly, there 
can be no text within the document. Index and party information areas are defined 
in the same manner as static documents, but they must contain graphic 
information, such as graphical representations of characters. A Dynamic 
Document cannot be defined as an image-based document. 

 
A Dynamic Document cannot be defined as an image-based document. 
The areas to be defined (index and party information) must contain graphic 
information, such as graphical representations of characters—areas to be 
defined cannot be empty. 
During extraction, image-characters under the border of the defined area 
will not be extracted; they may incorrectly display as other characters. 

• Selection Text: Any and all highlighted text from the previous step will appear in 
the Selection Text region.  

Note: The Selection Text area displays the currently selected text. If your selection 
region has picked up extra characters, click Cancel and redefine the region. 

Click Save. 

4 When Save is clicked, 
1. An entry is made in the document definition table stored on the server. 
2. A copy of the file is moved to the server SourcePDF folder for the FI selected 

during the definition. 
3. The title of the copied source file on the server is the same as the Full Name 

in the Extraction Details screen. 
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5 If you are defining a document that has an associated .XML file,  
The Added screen appears. 
Click OK to continue. 

 
This screen only appears when the Document Type is initially defined. 

 

6 The eSign Admin Manager screen refreshes. 

  
The Short Name appears and the document name region is highlighted in the 
document. 
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Defining FI Level Index Field Regions 
Define Index Type 
Indexes are necessary for your imaging system to successfully archive your document. First 
highlight the region, then select the Index. In this example we will define the Customer Name 
index field region. 

 
All defined documents must have at least 1 index field (Customer_Name, 
Customer_Number, etc.) before the document can be closed. 

 

1 Click the Define New Index icon (File > New > Define New Index) (Shift-F4). 
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2 The mouse cursor changes. 
Click and drag the mouse over the region of the document that will contain the 
information you are indexing. 

  
Click the mouse again when you complete highlighting the region on the document. 
Note: Remember to allow extra room as necessary for future document processing. 

In this template the entire Name region has been highlighted. 
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3 The Extraction Details screen appears. 
 1 Index Type: Select the Index Type from the dropdown list. 

 
In a new document, Customer_Name will be selected first by default. 

 2 Define New: The Define New button is used to create a new index field. Refer 
to Add/Edit/Define Index Fields on page 13 for more information.  

 3 Click Save. 

 

4 The eSign Admin Manager screen refreshes. 
The Index Type appears and the defined region is highlighted in the document. 

  
Repeat these steps as many times as necessary to define the index field type 
regions within each document. 

 

1 

 

2 

 

3 
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Reorder Index Type List 
1 When there are several index fields defined, you can change the order in which they 

are listed. 

 
Reordering the list has no effect on the actual Index. 

Select the Index field to be moved. 
Right-click on the field and select Move Up/Down or Click Extraction > Ordering > 
Move Up/Down to change the order. 
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Delete Index Type 
1 This delete function deletes a defined region from the current document; it does not 

delete the field from the database. 
Right-click on the Index Type in the list. 
Select Delete from the popup menu. 

 
Click Yes in the Confirm Delete popup window. 
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Change Index Type 
1 There are 2 methods to change the index type: Recreate or Edit Extraction Details 

1. Recreate the index 
a. Delete the Index Type (Delete Index Type on page 31). 
b. Redefine a new region (Define Index Type on page 27). 

2. Edit Extraction Details 
a. Select the Index Type to 

be changed. Right-click 
and select Edit or click 
Extraction > Edit 
Extraction. 

b. The Extraction Details 
screen appears. 

c. Click the down arrow in 
the Index Type selection box. 

d. Select a different Index Type. 
e. Click Save. 

 
From this screen you can also create a new Index Type. 
Click Define New. 
Refer to Add/Edit/Define Index Fields on page 13 for more information. 
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Modifying Document Level Indexing 
1 Click the View Indexes icon  (View > View Indexes). 

2 The Document Imaging Indexes screen appears. 
Only fields which have been marked as “Use for Imaging” in the View/Change Index 
Field Types screen are available on the Document Imaging Indexes screen. 
Additionally, if your system uses .XML files with field definitions, those defined fields 
will appear here. 
Areas in red will vary according to the Imaging System selected by the Administrator. 
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3 • To add an index field which has been marked as “Use for Imaging” in the current 
document, but has not been defined using the Define New Index button, 
o Select the Index Type from the pull down menu and click Add Index. 

• To remove an index field from the list, 
o Select the field to be deleted and click Delete Selected. 

 

4 
 

Column names will vary according to the Imaging System selected by the 
Administrator. 

In the upper part, all items can be edited except the Index Field Type. 

 
Information entered on this screen will take precedence over information entered at 
the FI Level (View/Change Index Field Types screen). 
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5 
 

Field names will vary according to the Imaging System selected by the 
Administrator. 

To change values in the lower part of the screen, 
Click Edit to unlock the lower section and display Imaging Indexes related 
information.  

• Use Following Default: Allows overwriting information from the XML with this 
value. 

Click Save to save any changes and lock the lower section. 
Click Cancel to discard any changes and lock the lower section. 
Click Close to close the Document Indexes screen. 
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Defining Text Fields 
1 Click the Design Text Fields icon (Fields > Design Text Fields). 

 

2 The mouse cursor changes. 
Click and drag the mouse over the region of the document that will contain the Text 
Field. 
Click the mouse again when you complete highlighting the region on the document. 
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3 The Field Details window appears. 
 1 Field Name: The name of the 

field. 
 2 Tool Tip: A descriptive 

explanation of the field. 
 3 Role/Type: The Role/Type of this 

field when processed through TeA 
RTS. Enables or disables the field 
based on signer. 
 Generic Locked: Locked if any 

signer has signed the session. 
(In branch processing only) 

 Generic Unlocked: Always 
unlocked regardless of 
signature status. (In branch 
processing only) 

 Party #: Field will be disabled 
after selected party has signed 
all documents in the session. 

 4 Default Value: The valued displayed for this field when processing through TeA 
RTS. 

 5 Index Field Textbox: When checked, allows associating the value of this field 
with any unassigned index field. When checked, Role/Type will default to 
Generic Locked. 

 6 Keep Unlocked for the selected party in remote signing: When checked, this 
keeps the field unlocked in DE during party signing. (Only enabled when item 3 
Party X is selected.) 

 7 Must Enter Value: During party signing, this field must be populated. (Only 
enabled when item 3 Party X is selected and item 6 is checked.) 

 8 Font Information: The Font Information can be altered to change the Font 
Name, Font Size and Alignment. 

 
The fonts listed in this section are pulled from fonts installed on the 
server. 

 9 Action Buttons: Click OK to save and continue. Click Cancel to prevent saving 
changes.  

1 

 2 

 3 

 4 

 

6 

 7 

 

9 

 

5 

 

8 
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4 The eSign Admin Manager screen refreshes. 
The Text Field appears and the defined region is highlighted in the document. 

• Field Name Rules 
o A field with Role/Type as Generic Locked or unlocked will display Field Name 

only. [Ex. TXT_COLLATERAL] 
o A field with Role/Type as Party will display Field Name with Party Number. [Ex. 

TXT_COLLATERAL (Party 1)] 

 
Defined text field areas will not hide or cover up any underlying elements 
when the PDF document is processed through IMM eSign RTS. 

 
 
Repeat these steps as many times as necessary to design text fields within each 
document. 
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Defining Checkbox Fields 
1 Click the Design Checkbox Fields icon (Fields > Design Checkbox Fields). 

 

2 The mouse cursor changes. 
Click and drag the mouse over the region of the document that will contain the 
Checkbox Field. 
Click the mouse again when you complete highlighting the region on the document. 
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3 The Field Details window appears, 
which allows the administrator to define 
the checkbox field with an appropriate 
field name. 
 1 Field Name: The name of the 

field. 
 2 Tool Tip: A descriptive 

explanation of the field. 
 3 Role/Type: The Role/Type of this 

field when processed through TeA 
RTS. Enables or disables the field 
based on signer. 
 Generic Locked: Locked if any 

signer has signed the session. 
(In branch processing only) 

 Generic Unlocked: Always 
unlocked regardless of 
signature status. (In branch 
processing only) 

 Party #: Field will be disabled after selected party has signed all documents 
in the session. 

 4 Default Value: The valued displayed for this field when processing through TeA 
RTS. 

 5 Index Field Textbox: Not used for this field. 
 6 Keep Unlocked for the selected party in remote signing: When checked, this 

keeps the field unlocked in DE during party signing. (Only enabled when item 3 
Party X is selected.) 

 7 Must Enter Value: During party signing, this field must be populated. (Only 
enabled when item 3 Party X is selected.) 

 8 Font Information: The Font Information can be altered to change the Font Size, 
which is used for the size of the tick mark placed in the checkbox during 
processing. 

 
The fonts listed in this section are pulled from fonts installed on the server. 

 9 Action Buttons: Click OK to save and continue. Click Cancel to prevent saving 
changes. 

1 

 2 

 
3 

 4 

 

6 

 7 

 

9 

 

5 

 

8 
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4 The eSign Admin Manager screen 
refreshes. 
The Checkbox Field appears and the 
defined region is highlighted in the 
document. 

• Field Name Rules 
o A field with Role/Type as Generic 

Locked or unlocked will display 
Field Name only. 
[Ex. TXT_COLLATERAL] 

o A field with Role/Type as Party will 
display Field Name with Party 
Number. [Ex. TXT_COLLATERAL 
(Party 1)] 

 
Repeat these steps as many times as necessary to design checkbox fields within 
each document. 

Checkbox Field Caption 
1 Select Add Caption to create a caption for a checkbox field.  

Right-click the Checkbox field. 
Select Add Caption from the dropdown menu. 
Or 
Right-click on the Checkbox Field in the Defined Field List and select Add Caption. 

 

Or 
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2 The mouse cursor changes. 

 
If you are continuing from defining a Checkbox field, the mouse cursor will 
not change. The mouse cursor will remain a pointing hand ( ). 

Click and drag the mouse over the region of the document that will contain checkbox 
caption. 
Click the mouse again when you complete highlighting the region on the document. 
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3 The Field Details window appears. 
In the Tool Tip field, enter a descriptive explanation of the Caption. 

 
The Field Name shows it is related to CHK_INDIVIDUAL. The TeS is for 
TotaleSign. 

The Font Information can be altered to change the Font Size to set the size of the 
text used in the Checkbox Field Label. 
Click OK. 
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4 The TotaleSign Admin Index Manager screen refreshes. 
The Checkbox Field Caption appears and the defined region is highlighted in the 
document. 

 

 
Caption areas will not hide or mask any underlying elements when the PDF 
document is processed through IMM eSign RTS. 

 
Repeat these steps as many times as necessary to design checkbox caption fields 
within each document. 
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5 In this example, the word “Variable” did not fully show within the region. 
Right-click the region,  
Select Edit. 
Change the font size to a smaller font. (We used 8.) 
Click OK. 
The smaller font size allows the full word to appear. 
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Defining Signature Fields (Not Applicable for Dynamic Documents) 

Signature Fields (Not Applicable for Dynamic Documents) 
1 Click the Design Signature Field icon (Fields > Design Signature Field). 

 



  IMM eSign 2019.2 SP1 
  Admin Manager Administrator Guide 

2/5/20  47 

2 The mouse cursor changes. 
Click and drag the mouse over the region of the document that will contain the 
Signature Field. 
Click the mouse again when you complete highlighting the region on the document. 

 

 
If the Signature Field size is incorrect, the signature may be truncated or 
distorted. 
The Signature Field size should be at least 0.4 in (H) x 1.2 in (W) and can 
be scaled up. 
The Signature Field width should not be more than three times its height. 
Signature Field size can be confirmed by processing the document and 
reviewing the archived document. 
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3 The Field Details window launches. 
The Field Name cannot be changed. 
 1 Signer: Select a Party from the Signer dropdown to associate with the signature 

in the field (more information in Defining Party Information on page 58). 
 2 Tool Tip: Enter a descriptive explanation of the signature field. 
 3 Required: When checked, the signature field must be signed during processing 

of this document. 
 4 Click OK. 

 

1 

 
2 

 

4 

 

3 
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4 The eSign Admin Manager screen refreshes. 
The Signature Field appears and the defined region is highlighted in the document. 

 
Repeat these steps as many times as necessary to design signature fields within 
each document. 
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Signature Date Fields (Not Applicable for Dynamic Documents) 

1 Select Design Signature Date to create unique signature dates for each signature 
field. 
Right-click the Signature field  
Or  
Right-click the Signature field name in the tree view. 
Select Design Signature Date. 
(Fields > Design Signature Date or right-click on the Signature Field in the Defined 
Field List and select Design Signature Date.) 

  

Or 
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2 The mouse cursor changes to a pointing finger. 
Click and drag the mouse over the region of the document that will contain the 
Signature Date. 
Click the mouse again when you complete highlighting the region on the document. 
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3 The Field Details window will launch, which allows the administrator to associate the 
signature date field with an appropriate signature field name. 
The Signature Date field is automatically associated with a Signature field.  
 1 In the Tool Tip field, enter a descriptive explanation of the signature date field. 
 2 The Font Information can be altered to change the Font Type, Font Size and 

Alignment. 
 3 Click OK. 
In the Tool Tip field, enter a descriptive explanation of the signature date field. 
The Font Information can be altered to change the Font Name, Font Size and 
Alignment. 
Click OK. 

 
3 

 

1 

 

2 
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4 The eSign Admin Manager screen refreshes. 
The Signature Date field appears and the defined region is highlighted in the 
document. 

 

 
Date field areas will not hide or mask any underlying elements when the 
PDF document is processed through IMM eSign RTS. 

 
Repeat these steps as many times as necessary to design signature date fields 
within each document. 
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Defining Initial Fields (Not Applicable for Dynamic Documents) 

1 In the document, scroll to the area that will contain the initials field. 
Click the Design Initials Fields icon (Fields > Design Initials Fields). 
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2 The mouse cursor changes. 
Click and drag the mouse over the region of the document that will contain the Initial 
Field. 
Click the mouse again when you complete highlighting the region on the document. 

  

 
If the Initial Field size is incorrect, the initials may be truncated or distorted. 
The Initial Field size should be at least 0.263 in (H) x 0.167 in (W) and can 
be scaled up. 
The Initial Field width should not be more than three times its height. 
Initial Field size can be confirmed by processing the document and 
reviewing the archived document. 
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3 The Field Details window launches, which is used by the administrator to define the 
signature field with an appropriate field name. 
The Field Name cannot be changed. 
 1 Signer: Select a Party from the Signer dropdown to associate with the initials in 

the field (more information in Defining Party Information on page 58). 
 2 Tool Tip: Enter a descriptive explanation of the signature field. 
 3 Required: When checked, the initial field must be completed during processing 

of this document. 
 4 Click OK. 

 
 

1 

 
2 

 

4 

 

3 
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4 The eSign Admin Manager screen refreshes. 
The Initials Field appears and the defined region is highlighted in the document. 

 
Repeat these steps as many times as necessary to design initials fields within each 
document. 
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Defining Party Information (Not Applicable for Dynamic Documents) 
What’s a Party? 
No hats or noisemakers. For our purposes, a Party is a person. Documents may have one or 
more parties included. Party fields are used throughout IMM eSign. 
If you are processing a document that contains information for more than one person, then 
the first person listed would be Party 1. The next person listed will be Party 2. Additional 
people will be Party 3, 4, etc.  
If you are processing an account application, the Member may be the only Party on the 
document. 
Party 1? 
In the case of a loan application that will be submitted for a digitized signature online, the first 
person listed (Primary Applicant) would be Party 1. Any co-applicants would be Party 2, 3, 
etc. Some loan applications only have room for 1 or 2 applicants, so an additional loan 
application may need to be submitted with only the remaining party information. Other 
documents may be submitted that only contain information for a single party. 
When using Remote Signatures and the document set is submitted for digitized signatures, 
Party 1 has to sign the document first, before Party 2 receives the document set for signing. 
Party 3 will only receive the document set after Party 1 and Party 2 have signed the 
documents. 
Party Name (Party 1, Party 2, etc.) definitions are used to associate other related fields 
together. Signature Fields for Party 1, Address Fields for Party 1, etc. – all will be associated 
by the Party 1 Name Field. 

 
Party fields will be used to populate the IMM eSign Remote Signature screen.  
Regions used for Index Fields can also be used for Party information.  
Only the following Party fields are required for processing documents with signature 
blocks: 

1) Customer Name - Customer Name is typically first and last name together. 
The individual parts of Customer Name could also be used for Party - First 
Name and Party - Last Name. 

2) Email  
3) Phone 

Additional fields in examples are not required to be defined. 
Party fields can overlap index fields. 
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1 Click the Add Party Information icon (Party > Add Party Information) (Shift-F5). 

 

2 The mouse cursor changes. 
Click and drag the mouse over the region of the document that will contain the Party 
Field. 
Click the mouse again when you complete highlighting the region on the document. 

 
Party fields can overlap index fields. 
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3 The Party Details window appears, which allows the administrator to select the party 
and select the information with an appropriate field name. 
This information will be used to populate the fields in the Remote Signature screen. 
Documents in Remote Signature are chained together based on the name of the 
applicant.  
Select a Party from the dropdown.  
If this is the first party being defined, 
Select Party 1. 
For Applicant Information, either FULLNAME or LASTNAME and FIRSTNAME 
must be defined. This example will use FULLNAME. 
Select FULLNAME from the dropdown. 
Click OK. 

 

 
The FULLNAME or LASTNAME and FIRSTNAME party information fields 
cannot be deleted. The entire Party # section must be deleted to edit these 
fields. 

 



  IMM eSign 2019.2 SP1 
  Admin Manager Administrator Guide 

2/5/20  61 

4 The TotaleSign Admin Index Manager screen refreshes. 
The Party Information appears and the defined region is highlighted in the document. 

 

5 There are two email fields available for party definitions – HomeEmail and 
WorkEmail. The same procedure is used for both fields. 
Let’s define the HomeEmail (Address) for Party 1. 
Click the Add Party Information icon (Party > Add Party Information) (Shift-F5). 
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6 The mouse cursor changes. 
Click and drag the mouse over the region of the document that will contain the Party 
Field. 
Click the mouse again when you complete highlighting the region on the document. 
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7 The Party Details window appears. 
Since we just defined FULLNAME for Party 1, Party 1 remains selected. 
Select HOMEEMAIL for the Type of Extraction. 
Click OK to close the Party Details window. 
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8 The eSign Admin Manager screen refreshes. 
The Party Information appears and the defined region (HOMEEMAIL) is highlighted 
in the document. 

 

9 This similar document has information for multiple parties. 
Define the Name for Party 2. 
Click the Add Party Information icon (Party > Add Party Information) (Shift-F5). 

 



  IMM eSign 2019.2 SP1 
  Admin Manager Administrator Guide 

2/5/20  65 

10 The mouse cursor changes. 
Click and drag the mouse over the region of the document that will contain the next 
Party Field. 
Click the mouse again when you complete highlighting the region on the document. 
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11 The Party Details window launches. 
Select a Party from the dropdown. Since this is the second party being defined, 
Select Party 2. 
As name is required information, only LASTNAME, FIRSTNAME or FULLNAME can 
be selected at this time. 
Select FULLNAME from the dropdown. 
Click OK. 
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12 The eSign Admin Manager screen refreshes. 
The Party Information appears and the defined region is highlighted in the document. 

 

13 Repeat these steps as many times as necessary to add all party-related field 
definitions to the document. 
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Deleting a Document Definition 
Delete from Defined Document List 

1 From the eSign Admin Manager window, 
Click File > List Defined Documents. 
Or 

Click the List Defined Documents icon . 

 

2 The Defined Documents List window appears. 

 
• Column definitions are listed under the Extraction Details window on page 24.  
• The top row in each column allows filtering the selection.  

o Filters are data-specific (text or Boolean). 
o The default text filter selection, or constraint, is “Contains” and the default value 

is empty, which causes all rows to appear. The default data filter selection is 
“Equals”, which filters based on the icon in the filter row. 

Click the filter icon to choose a type of constraint. Click the constraint (Contains, 
Starts with, etc.) to enter text. Select one or more documents. 
Click Delete Selected. 
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3 The Confirm Delete text box appears. 
Click Yes. 
The documents are deleted. 
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Delete by Deleting Extraction 
1 From an open document, 

Click Extraction > Delete Extraction. 
Or 
Right-click on the Document Type and select Delete. 

 

2 The Confirm Delete text box appears. 
Click Yes. 

 

3 The page refreshes with all index and field information deleted. 
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Closing a Document 
Click File > Close File. 
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Managing Attached Documents 
An Attached Document is a PDF document not in the normal IMM eSign document system. 
This could be a scanned driver’s license, passport, a written set of instructions, or any other 
document in PDF format. 
No documents are created or used when they are defined. This is more like a type or 
category than an actual document. You can scan a passport and save it as a PDF document 
with any name. When the document is added into the document set, the Full Name and 
filename will be required information. 
Refer to the User Guide for information on adding and using attached documents. 

1 From the eSign Admin Manager screen, 
Click File > Manage Attachments.  
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2 The Manage Attachments screen appears. 
Existing Attached Document definitions are listed in the top. 
Clicking a column title alternates between sorting ascending or descending. 
The top row in each column allows filtering the selection. The default filter selection, 
or constraint, for Text fields is “Contains” and the default value is empty, which allows 
display of all rows. The default filter selection, or constraint, for checkbox fields is “No 
filter” and the default value is empty, which will display all rows. Click the filter icon to 
choose a type of constraint. Click the constraint (Contains, Starts with, etc.) to enter 
text. 
Click Close to close the Manage Attachments screen. 

 

Filter Row 
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Add an Attach Document Definition 
1 Click Add. 

The Manage Attachments screen unlocks for editing. 
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2 Enter information for 
 1 Short Name: Used in creating the filename for saved sessions. The Short 

Name is used for the Document Set Name on the Saved Session Details 
screen. (20 characters maximum) 

 
Short Name and Full Name can only have A-Z, 1-9 and Underscore (_). 
Spaces are not allowed. 

 2 Full Name: Used in creating the filename for archived documents. For 
attachments, the document name is more like a type or category than an actual 
name. You can scan a driver’s license and save it as any file name. When the 
document is added into the document set, the Short Name and the filename will 
be required information. Used in creating the filename for archived documents. 
The Full Name is used in indexing and defaults to the current filename, but can 
be modified at this point. (100 characters maximum) 

 3 Description: An easy to recognize description of the document. (150 characters 
maximum) 

 4 Archive Document: When checked, the document will always be archived as 
soon as a session is complete. When not checked the document may still be 
optionally archived. 

 5 Action Buttons: 
 Click Save to save the changes and add the information to the list. 
 Click Cancel to clear the Document Details section with no changes saved. 
 Click Close after all definitions have been added. 

 

1 

 2 

 3 

 4 

5 
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3 The Manage Attachments screen refreshes listing the attachment. 

• Edit Indexes: Clicking this button displays the Document Imaging Indexes screen. 
Refer to page 33 for more information. Only active when editing an existing 
attachment. 

 
Only indexes which have Use For DMS checked at the FI Level will 
appear on the Document Imaging Indexes screen. 

Repeat as necessary. 
Click Close when done. 

 

Edit an Attach Document Definition 
1 Double-click an attachment row. 

The Document Details unlock for editing. 
Make changes as necessary. 
Edit Indexes as necessary. 
Click Save to save the changes and add the information to the list. 
Click Cancel to clear the Document Details section with no changes saved. 
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Delete an Attach Document Definition 
1 Click a definition. 

Click Delete. 

 

2 Click OK on the Warning popup. 
The definition is removed from the list. 
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Remote Attachment Template 
Remote Attachment Templates are groups of attachment definitions that can be associated 
with discrete processes (Car Loan, Home Loan, etc.)  
Remote Attachment management is performed using IMM eSign RTS Administrator functions. 
Click File > Remote Attachment Template. 

 
This action will open IMM eSign RTS in a browser window. 
eSign Admin Manager will remain open during this operation. 

 
The Remote Attachment Template Maintenance page appears in your browser. 

 
Refer to the Administrator Guide for an explanation of this page. 
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Exporting and Importing Defined Documents 
Exporting/Importing defined documents is a two-part process. Exporting/Importing the Defined 
Document List and Exporting/Importing the Defined Documents are separate processes. Both 
processes are explained. Exporting/Importing the documents are necessary if changes will be 
made by the receiving Financial Institution. 

 
1. Fonts used for text fields (Defining Text Fields, page 36) are dependent on 

fonts installed on the server.  
A document exception during processing may occur if the document is defined 
and imported on a server that does not have the same font available. 

2. Attachments cannot be exported or imported. 

Defined Document List on the AIM Administrator Machine 
Defined Document List databases are stored on the server for each Financial Institution, making 
it possible to use copies of a single or master Defined Document List database on multiple 
Financial Institutions. 

Export List 
1 From the TotaleSign Admin Index Manager window. 

Change Financial Institution as necessary to select the source FI (Starting Admin 
Index Manager, page 7). 
Click File > List Defined Documents. 
Or 

Click the List Defined Documents icon . 
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2 The Defined Documents List window appears. 

 
• Column definitions are listed under the Extraction Details window on page 24.  
• The top row in each column allows filtering the selection.  

o Filters are data-specific (text or Boolean). 
o The default text filter selection, or constraint, is “Contains” and the default value 

is empty, which causes all rows to appear. The default data filter selection is 
“Equals”, which filters based on the icon in the filter row. 

Click the filter icon to choose a type of constraint. Click the constraint (Contains, 
Starts with, etc.) to enter text.  
Select the document(s) to be exported. 
Click Export Selected. 

3 The Save As window appears. 
The default location is  

InstallPath%\Admin\IndexFiles. 

4 Navigate to a target folder. 
Enter a File Name. 

 
The list will be exported in .Zip format. 

 

5 The Successfully Exported X items message 
appears. 
Click OK. 
The list is exported and you return to the 
TotaleSign Admin Index Manager window. 

 
This procedure only exports the 
Document Definition List. The 
associated files are not exported and 
must be done separately. 
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Import List 

 
Documents included in Defined Document Lists created in prior versions of TeSign 
Admin Index Manager can be imported into TeSign Admin Index Manager 2019.2 
SP1. 

 

1 From the eSign Admin Manager window. 
Change Financial Institution as necessary (Starting Admin Index Manager, 
page 7). 
Click File > Import Defined Documents. 

 

2 The Open window appears. 
Navigate to the location where the Zip file is stored. 
Select the Zip file. 
Click Open. 

3 The Import Defined Documents window appears. 
Column definitions are listed under the Extraction Details window on page 24.  
By default, all documents are selected. 
Select any or all documents to be imported. 
Click Import Selected. 
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4 The Successfully Imported X items message 
appears. 
Click OK. 
The list is imported and you return to the 
TotaleSign Admin Index Manager window. 

 
This procedure only imports document 
definitions. The associated PDF files 
are not imported and must be done 
separately. 
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Defined Documents on the Server 
Export Documents 

1 On the server, navigate to C:\IMM\TeAASPFiles\FI#\SourcePDFs. 

• Each FI (FI#) stores its own documents in the SourcePDFs folder. 
Select the PDF files to be exported. 
Right-click and select Send To > Compressed (zipped) Folder. 

 

2 Rename, copy and distribute the .zip file as necessary. 

 

Import Documents 
1 On the server, navigate to the folder containing the compressed folder (.zip file). 

Right-click on the file and select Extract All. 
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2 The Select a Destination and Extract Files popup appears. 
Use the Browse button to select an extraction location on the server (Default 
Location: 
C:\IMM\TeAASPFiles\FI#\SourcePDFs, 

Where FI# is the FI Number associated with your Financial Institution). 
Click Extract. 
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Imported Documents Permissions 
1 On the server, 

Navigate to the SourcePDFs folder (Default Location:  
C:\IMM\TeAASPFiles\FI#\SourcePDFs, 

Where FI# is the FI Number associated with your Financial Institution). 
Right-click on the folder name and  
Select Properties from the menu. 
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2 The SourcePDFs Properties window appears. 
 1 Select the Security tab. 
 2 Click Advanced. 

 

1 

 

2 
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3 The Advanced Security Settings for SourcePDFs window appears. 
 1 Check the checkbox for Replace all child object permissions with inheritable 

permissions from this object. 
 2 Click OK. 

 

4 The Windows Security window appears. 
Click Yes. 

 

5 Click OK, OK. 
Close all open windows. 

 

1 

 2 
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ProSign Documents (Only available if the TeSign Zip Files Add-On is activated.) 

 
If you switch from an FI that does not have .zip files to an FI that uses .zip files, you 
must restart TotaleSign Admin Index Manager. 

All documents from the .zip files must be defined as described in this guide. 
To prepare for extracting files: 

1 Create a temporary folder (Ex. C:\Program Files\IMM\TotaleSign\Admin\Temp). 

2 To assist in identifying new extracted PDF documents to be defined, you can create 
a folder C:\Program Files\IMM\TotaleSign\Index Files\Base Documents and move all 
currently-defined documents from C:\Program Files\IMM\TotaleSign\Index Files to 
the new folder. 
Copying the .zip folders into C:\Program Files\IMM\TotaleSign\Index Files will help in 
the following steps. 

3 After the TeSign Zip add-on is activated and the password has been entered, a new 
menu choice appears in AIM: Tools. 
 

 

4 Click Tools > Zip Files > ProSign. 
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5 The Select a Zip file to Extract From screen appears. 
 1 Browse to the .zip file location. 
 2 Click Open. 

 

7 The embedded PDF documents will be extracted to the default document location 
(Default: C:\Program Files\IMM\TotaleSign\Admin\IndexFiles). 

8 Define all documents as described in this guide. 

 

1 

 

2 
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Contact IMM Support 
Feel free to contact us with any issues or concerns. 
 
Phone: 800.836.4750 Option 3 (8:30am - 10:30pm ET) 
Fax: 908.862.6446 
Email: support@immonline.com  
 
 
 
 
 
2 City Hall Plaza 
Rahway, NJ 07065 
 

mailto:support@immonline.com
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